FPS maxing out at 30 on .75 client

Alright so I haven’t been able to play .75 for a week now. I’ve tried a bunch of “solutions” but nothing has had an effect. When I join a server on the .75 classic client my fps will max out at 30. Sometimes it will jump around at 50 but if I alt+tab out of the game and rejoin it drops to 30, if I break a few blocks it drops to 30, or if I inject it drops to 30. This all started after a recent windows 10 update but others aren’t having the problem. At least one other person is having this same problem. Any help would be helpful.

system specs:
i5 7600k 3.8GHz
gtx 1060 6gb
16gb DDR4 2400 g.skill ram

I read that some fps problems could happen with the creators update. You probably already tried this but just in case…

  1. Go in C:\Ace of Spades
  2. Right click on client.exe
  3. Compatibility
  4. Disable fullscreen optimizations

omg i thought i was going crazy, my classic aos is laggy as well on latest win 10

This didn’t do anything for me. Muffins advice was to change screen resolution to 720 and then game resolution to 720 windowed. It’s close enough to fullscreen that the gameplay doesn’t change and all my fps problems are gone.

same problem, didn’t fix anything

AFAIK, GPU doesn’t matter for .75, it doesn’t use the GPU to render anything.
This helped me on my old Windows 8, might work for you too.
Also might try this (font is way better even if fps doesn’t increase)